Skip to main content

EBS R12.2.4 AutoConfig could not successfully execute the following scripts followed by error "txkGenADOPWrapper.pl INSTE8_APPLY 1"

issue:txkGenADOPWrapper.pl    INSTE8_APPLY       1

WARNING: [AutoConfig Error Report]
The following report lists errors AutoConfig encountered during each
phase of its execution.  Errors are grouped by directory and phase.
The report format is:
      <filename>  <phase>  <return code where appropriate>
  [APPLY PHASE]
  AutoConfig could not successfully execute the following scripts:
    Directory: /u01/applprod/fs2/FMW_Home/webtier/perl/bin/perl -I /u01/applprod/fs2/FMW_Home/webtier/perl/lib/5.10.0 -I /u01/applprod/fs2/FMW_Home/webtier/perl/lib/site_perl/5.10.0 -I /u01/applprod/fs2/EBSapps/appl/au/12.0.0/perl -I /u01/applprod/fs2/FMW_Home/webtier/ohs/mod_perl/lib/site_perl/5.10.0/x86_64-linux-thread-multi /u01/applprod/fs2/inst/apps/PRODDB_epc-apps12-node41v/admin/install
      txkGenADOPWrapper.pl    INSTE8_APPLY       1
 
AutoConfig is exiting with status 1
 
Solution:
This happens occasionally when old nodes are left in 12.2 tables.
 
Autoconfig Error: ORA-01422: Exact Fetch Returns More Than Requested Number Of Rows (Doc ID 2212698.1)
 
This should be resolved by running:
check by bellow query if any misconfiguration node added in fnd_nodes
select node_name from fnd_nodes;
on DB Tier:
 
  1. execute fnd_conc_clone.setup_clean 
  2. Autoconfig on DB (adautocfg.sh)
 
Apps Tier:
  1. login and source enviorment file
  2. Run adautoconfig
  3. verify nodes by select node_name from fnd_nodes;
  4. Start service (if it is stopped)
 for patch FS 
  • Autoconfig on Patch fs --ignore errors
  • Autoconfig on Run fs --Should complete successfully now


 

Comments

Popular posts from this blog

How To Create LVM Using vgcreate in Linux

Logical Volume Management (LVM) creates a layer of abstraction over physical storage, allowing you to create logical storage volumes. With LVM in place, you are not bothered with physical disk sizes because the hardware storage is hidden from the software so it can be resized and moved without stopping applications or unmounting file systems. You can think of LVM as dynamic partitions. For example, if you are running out of disk space on your server, you can just add another disk and extend the logical volume on the fly. Below are some advantages of using Logical volumes over using physical storage directly: •Resize storage pools: You can extend the logical space as well as reduce it without reformatting the disks. •Flexible storage capacity: You can add more space by adding more disks and adding them to the pool of physical storage, thus you have a flexible storage capacity. •Use of striped, mirrored and snapshot volumes: Striped logical volume that stripes data across two or ...

EBS Standby Role Tranistion using standby database and standby application Tier

 Role Transitions A database can operate in either a primary or standby role - these roles are mutually exclusive. Oracle Data Guard enables you to change these roles dynamically by issuing SQL commands, and supports the following transitions: Switchover Allows the primary database to switch roles with one of its standby databases. There is no data loss during a switchover. After a switchover, each database continues to participate in the Oracle Data Guard configuration with its new role. Failover Changes a standby database to the primary role in response to a primary database failure. The following role transitions are discussed: 6.1 Performing a Switchover 6.2 Performing a Failover 6.3 Performing a Switchback to the Primary Following A Switchover/Failover Each of these three transitions requires some application configuration to be performed. Most of the application configuration step...
TRANSPARENT APPLICATION FAILOVER FOR RAC RAC provides near-continuous availability by hiding failures from end-user clients and application server clients. This provides continuous, uninterrupted data access. Transparent Application Failover (TAF) is what applications use to sync up with Oracle RAC availability. TAF in the database reroutes application clients to an available database node in the cluster when the connected node fails. Application clients do not see error messages describing loss of service. if the users connection to Node 1 dies, their transaction is rolled back but they can continue work without having to manually reconnect. To get a good understanding of how the TAF architecture works, it is helpful to walk through a failover scenario where a user is querying the database to retrieve 1000 rows from the database. Assume that the user is connected to Node 1/ Instance 1. 1.      The heartbeat mechanism between the various nodes...